this post was submitted on 15 Nov 2024
50 points (96.3% liked)

Programming Horror

239 readers
1 users here now

Welcome to Programming Horror!

This is a place to share strange or terrible code you come across.

For more general memes about programming there's also Programmer Humor.

Looking for mods. If youre interested in moderating the community feel free to dm @[email protected]

Rules

Credits

founded 2 years ago
MODERATORS
 
top 9 comments
sorted by: hot top controversial new old
[โ€“] [email protected] 18 points 2 months ago (1 children)

smh, could have used the short form ()=>{ instead of function ๐Ÿ˜ค

[โ€“] [email protected] 11 points 2 months ago

I've been coding long enough that I still think of that as a fairly new thing in JS.

[โ€“] [email protected] 11 points 2 months ago (1 children)
[โ€“] [email protected] 6 points 2 months ago

Someone's handed me nested base-64 encoded JSON before and to this day I am moderately annoyed at them.

[โ€“] [email protected] 10 points 2 months ago (1 children)

I WILL NOT USE ANOTHER LINE. I DON'T NEED IT

[โ€“] [email protected] 5 points 2 months ago (1 children)

The best code has the fewest lines.

[โ€“] HelloHotel 1 points 2 weeks ago* (last edited 2 weeks ago)

This is just as easy to write, just as sloppy but hopefully way easier to read.

Game.onload = (data)=>{
let a = data;
a = JSON.decode(a)["saveGame"][0];
a = JSON.decode(a)["SaveGame"];
return a;
}
[โ€“] [email protected] 10 points 2 months ago

In German we say "doppelt hรคlt besser". Is there an English saying like that? "Twice is stronger/more stable/holds better."

[โ€“] [email protected] 10 points 2 months ago

Why settle on cammel case ("saveGame") or upper cammel case ("SaveGame") when you can have one of each?