1
344
submitted 2 months ago* (last edited 2 months ago) by ljdawson to c/syncforlemmy

Key points

  • Message notifications are back!
  • A big refresh to messaging
    • Added a new unified inbox option "all" combining comment replies, mentions and direct messages
    • Quick action buttons are now shown for comment replies, mentions and direct messages
    • Comment reply actions (more icon) now shows the user and community rows (with additional options)
    • Comment replies now show the community icon and post title
    • Comment replies have had a visual refresh
    • Comment replies, mentions and direct messages can now be quickly reported and marked as read
    • Comment replies, mentions and direct messages can now be marked as unread
    • Added a quickly reply swipe gesture
    • Added page dividers
    • Your own send direct messages can now be deleted
    • Direct messages are now shown in threads

New

  • Added .webm support to the image viewer and image peek
  • Added "linked instances" and "blocked instances" to the instance chip group

Changes

  • Experimenting with always showing the community icon in feeds
  • Updated the reply icon

Github issues closed

  • View mode not updating properly #402
  • No messages returned snackbar doesn't automatically go away #333
  • Add ability to disable "view more" toast messages #365
  • Allow images in comments to use shared element transitions #391
  • Add new app icons to replace the legacy S4R ones that were removed #389
  • Add option to swap upvote and down vote colors to match Lemmy #386
  • Username doesn't show in the account picker if there is no display name #451
  • Account settings save button not disappearing after saving #448
  • When swapping between automatic and manual theming, some elements don't change color properly #479
  • Override sort dialog shows cancel button twice #484
  • Username of non active account in account picker is empty #492
  • Crash on startup with latest update #445
  • Missing username in picker #478
  • Not showing link options properly and crashing when clicked #513

Other fixes

  • Fixed a title displaying issue caused by the recent change to titles
  • Fixed a crash when clicking link options on a text post
  • Fixed a bug where the description of the current messaging section in the toolbar wouldn't update correctly
  • Fixed an issue with a broken lift target in messaging causing the status bar not to change color

v122 adds support for a super secret upcoming new feature...

2
69
Markdown tests (self.syncforlemmy)
submitted 3 months ago* (last edited 3 months ago) by ljdawson to c/syncforlemmy

If you come across something that doesn't work pop it here

3
197
Sync for Lemmy status page (syncforlemmy.betteruptime.com)
submitted 3 months ago* (last edited 3 months ago) by ljdawson to c/syncforlemmy

Evening all.

I've created a status page to monitor all services I maintain to run Sync for Lemmy.

There's not too many at the moment but will keep updating as I create new APIs etc.

Cheers, Lj

4
290
Upcoming releases (self.syncforlemmy)
submitted 3 months ago by ljdawson to c/syncforlemmy

Hey everyone.]

So update 98/99 has gone live which fixes the crashes (thanks for the reports).

I'm gearing up for a pretty sizable release but just wanted to check in and ask if there was any issues you're having that I should know about or any new feature requests.

Sorry for the bad comms but I'm making my way through lots of messages and posts on here. Thanks for the patience as I get through these all.

Cheers, Lj

5
22
submitted 5 days ago* (last edited 5 days ago) by [email protected] to c/syncforlemmy

Recently I started noticing that a lot of posts will mark as read for a second then go back to unread when viewing just the image or article. It's not all posts though and I haven't determined a pattern yet, but opening the comments seems to mark as read on refresh even though the post looks unread before refreshing.

I'm on version 122 of Sync on Android.

6
43
submitted 1 week ago by [email protected] to c/syncforlemmy

Starting yesterday, when I click a link to view the image or comments, the link doesn't appear "read" when I go back to the feed.

I know Sync hasn't updated, but yesterday I updated Chrome and rebooted my phone, in case that's relevant.

I keep clicking the same posts over and over and can't use Hide Read option to only see new stuff.

7
10
submitted 1 week ago by johannesvanderwhales to c/syncforlemmy

I can't see what I'm typing in landscape orientation. I type in landscape 100% of the time.

8
5
submitted 1 week ago* (last edited 1 week ago) by [email protected] to c/syncforlemmy

It happened recently, the share function doesn't seem to be pulling the URL from the page.

Edit: this is with Firefox mobile beta 127.0b9 as my default browser

9
5
submitted 1 week ago by Knitwear to c/syncforlemmy
10
10
submitted 1 week ago* (last edited 1 week ago) by [email protected] to c/syncforlemmy

This is not happening on every post, but I'm seeing "There are no comments" more and more on posts where there are comments. The comment counter in the example pic shows 8. And I know there is at least one (I made a comment).

Any ideas?

Edit: I did try clearing cache and storage with no effect.

11
6
submitted 2 weeks ago* (last edited 2 weeks ago) by [email protected] to c/syncforlemmy

How can I see totals per up and down vote in sync? Right now it combines them.

12
3
Images not showing in body (lemmy.blahaj.zone)
submitted 2 weeks ago* (last edited 2 weeks ago) by [email protected] to c/syncforlemmy

Not sure if it's just me but I've noticed I've never seen any images in the body of a post on sync, though I have on a browser. I assumed in the past the user just forgot to add images but I now found a button to open them. Are they meant to be embedded in the large empty space?

Just incase this issue is widespread and nobody can see, Il note that I have attached 3 images showing the issue.

Device information

Sync version: v24.03.26-14:56    
Sync flavor: googlePlay    

Ultra user: false    
View type: Cards    

Device: Nord    
Model: OnePlus AC2003    
Android: 11
13
2
submitted 2 weeks ago by [email protected] to c/syncforlemmy

Can someone please check this comment I made and let me know if you see the inline image?

14
5
submitted 2 weeks ago by [email protected] to c/syncforlemmy
15
12
submitted 2 weeks ago by alldreadme to c/syncforlemmy

I had posted this a few months and it's still the same issue.

If I search for a community using sync it only shows around 6-7. And that is also in the explore bar, it doesn't do the search in the dedicated search page.

Am I doing something wrong or is this still the case?

16
6
submitted 2 weeks ago by [email protected] to c/syncforlemmy

As the title asks, is it possible to migrate the settings for an account to a new phone? Would hate to have to set it up again..

17
20
submitted 3 weeks ago by SPRUNT to c/syncforlemmy

I think a lot of people forget to check where they are before replying to things (me especially). Serious replies show up in shitposts and are then apologized for, joke comments are made in communities that are more serious, etc.

I was thinking it'd be nice to have the option to make me click through a confirmation of the community I'm in before crafting a data-driven response to something in an askmelolz group.

Bonus points for making it big and colorful :D

18
68
submitted 3 weeks ago* (last edited 3 weeks ago) by [email protected] to c/syncforlemmy

Sync grabs images using an option for max length of 1500px, so the super long images are just a smattering of pixels that barely represent the original image.

I can't find a way in the app to get a better quality version. I end up opening a web browser to view.

19
19
submitted 3 weeks ago* (last edited 3 weeks ago) by Crackhappy to c/syncforlemmy

Edit: I'm pretty sure that I made a mistake here, in that I tried to use my main credentials to sign in and transfer, but I actually bought the lifetime on a different account. The likelihood that I confused myself with my paranoia is likely high.

20
5
Can't see comment replies (self.syncforlemmy)
submitted 3 weeks ago by victorz to c/syncforlemmy

Hey all. I'm having this issue where a bunch of content replies disappear on me. Or, rather, they are in my inbox, but when I click them to go reply and vote on them in the comments of the post where they are, they are completely missing from the thread/conversation. So to make it clear, they never disappear from my inbox, but they just can't be seen in the comments section itself, under the associated post.

Is this a bug or expected behavior?

Thanks for any help.

21
22
submitted 4 weeks ago by [email protected] to c/syncforlemmy

Links that open natively in Sync (like news articles) are often riddled with ads. Is there any way for the Sync shell to open through a Firefox based browser, which includes native ad block?

I'm not sure if this is related to what browsers I have on my phone. I do have one chromium based browser (kiwi) installed, and if getting rid of that would fix the problem I could look into deleting it and leaving only FF on my phone. But I'm not sure if it's related.

22
16
submitted 1 month ago* (last edited 1 month ago) by Stovetop to c/syncforlemmy

When Samsung last updated One UI several months ago, myself and many other Samsung users (and Pixel users on Android 14 as well, judging by the replies) encountered a bug where swiping posts closed showed only a black background until fully closed, after which the content one would expect to see would appear.

Last night, One UI updated to 6.1 on my device, and when I used Sync this morning, I noticed that the black background bug is no longer happening.

!Unfortunately I now need to re-learn my navigation gestures because Samsung apparently thinks it's fine to force people to completely re-learn how they navigate their phone overnight...!<

Device information

Sync version: v24.03.26-14:56    
Sync flavor: googlePlay    

Ultra user: true    
View type: List    

Device: p3q    
Model: samsung SM-G998U    
Android: 14
23
8
submitted 1 month ago by Anticorp to c/syncforlemmy

I've added some instances to the instance filters, yet I continue seeing those instances. Is there something else that I need to do to block entire instances?

24
16
submitted 1 month ago by [email protected] to c/syncforlemmy

I'm seeing within Sync a number of users have profile pics that show up on their posts. Is there a way in Sync to set that?

25
14
submitted 1 month ago by [email protected] to c/syncforlemmy

I am trying to block all posts that are links to YouTube on my feed. I tried domain filtering for all 4 of the domains that the YouTube app auto opens. But I still see YouTube link posts. I tried logging out and back in, no luck. Anyone know?

view more: next ›

Sync for Lemmy

14938 readers
11 users here now

👀


Welcome to Sync for Lemmy!

Download Sync for Lemmy


Welcome to the official Sync for Lemmy community.

The rules for posting and commenting, besides the rules defined here for lemmy.world, are as follows:

Community Rules


1- No advertising or spam.

All types of advertising and spam are restricted in this community.



Community Credits

Artwork and community banner by: @[email protected]


founded 1 year ago
MODERATORS