this post was submitted on 11 Oct 2023
45 points (94.1% liked)

Programming

17763 readers
601 users here now

Welcome to the main community in programming.dev! Feel free to post anything relating to programming here!

Cross posting is strongly encouraged in the instance. If you feel your post or another person's post makes sense in another community cross post into it.

Hope you enjoy the instance!

Rules

Rules

  • Follow the programming.dev instance rules
  • Keep content related to programming in some way
  • If you're posting long videos try to add in some form of tldr for those who don't want to watch videos

Wormhole

Follow the wormhole through a path of communities [email protected]



founded 2 years ago
MODERATORS
you are viewing a single comment's thread
view the rest of the comments
[–] exussum 1 points 1 year ago (3 children)

This makes me want to write a function for you to add to numbers where the variables are leftumber and rightnumber, instead of x and y.

[–] eager_eagle 4 points 1 year ago (1 children)

if "left" and "right" were relevant for addition, they would indeed be better names

[–] exussum 1 points 1 year ago (1 children)

Are you against using a single letter variable like e for element in iterating over things?

[–] eager_eagle 3 points 1 year ago (1 children)
[–] exussum 1 points 1 year ago (1 children)

To each their own. But man imagine if you have a collection of stuff that has a large name, and then having to figure out a short name other than e when iterating. I hope you're not iterating over chemical names 😬

[–] eager_eagle 3 points 1 year ago

No need to be over-descriptive. Anything at all more specific than e will probably be a better name

[–] [email protected] 1 points 1 year ago

Implementing add (and other math operations) in rust for your types has the type signature self and rhs (right hand side).

[–] [email protected] 1 points 1 year ago (1 children)

Lhs and rhs are much better than x and y

[–] exussum 1 points 1 year ago (1 children)

In what way? If you encountered a function that had x and y which just added them together, that's not readable enough?

[–] [email protected] 1 points 1 year ago

Well in a vacuum yes sure, you're right, but in practice there's always some context. x and y could be referring to axes, where an addition makes little sense. However lhs and rhs make more sense if you're overloading an operator